# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bp(ost|ostal)?(([ \.]*(O|0|o)(ffice)?)|([ \.]*box))([ \.]*Box)?\b"
test_str = ("po box 1272\n"
"po box 29407\n"
"3001 p street suite a\n"
"po box 882\n"
"490 post st ste 700\n"
"530 post cpurt\n"
"530 post ct\n"
"postal box 1216\n"
"2 mile klondike highway po box 440\n"
"mile 1.5 klondike hwy po box 535\n"
"346 a tundra way po box 324\n"
"7307 s frontier drive/po box 877509\n"
"4540 edinburgh dr. po box 545, king salmon\n"
"650 oliver rd. po box 241702\n"
"#320 fortaleza street, po box 9024070,\n"
"10 el campo\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.