# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.(?![^<]*\\/>)/*/gm;t' <<< "Hi. the symbol before me is my match target <img src='http://skip.these.dots/and.this.as.well' alt='me.three' /> but still match this.
"