const regex = /\.(?![^<]*\/>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(?![^<]*\\\/>)', 'gm')
const str = `Hi. the symbol before me is my match target <img src='http://skip.these.dots/and.this.as.well' alt='me.three' /> but still match this.
`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);