re = /\.(?![^<]*\/>)/m
str = 'Hi. the symbol before me is my match target <img src=\'http://skip.these.dots/and.this.as.well\' alt=\'me.three\' /> but still match this.
'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result