use strict;
my $str = 'Hi. the symbol before me is my match target <img src=\'http://skip.these.dots/and.this.as.well\' alt=\'me.three\' /> but still match this.
';
my $regex = qr/\.(?![^<]*\/>)/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";