package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-?\d+(?:\.\d+)?$`)
var str = `$ 8
$ 12.548
$ -8
$ -6.098
$ -59
$ 778
$ 73
$ 12.548a
$ -59x
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}