import re
regex = re.compile(r"-?\d+(?:\.\d+)?$", flags=re.MULTILINE)
test_str = ("$ 8\n"
"$ 12.548\n"
"$ -8\n"
"$ -6.098\n"
"$ -59\n"
"$ 778\n"
"$ 73\n"
"$ 12.548a\n"
"$ -59x\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")