import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-?\\d+(?:\\.\\d+)?$";
final String string = "$ 8\n"
+ "$ 12.548\n"
+ "$ -8\n"
+ "$ -6.098\n"
+ "$ -59\n"
+ "$ 778\n"
+ "$ 73\n"
+ "$ 12.548a\n"
+ "$ -59x\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}