const regex = new RegExp('-?\\d+(?:\\.\\d+)?$', 'gm')
const str = `\$ 8
\$ 12.548
\$ -8
\$ -6.098
\$ -59
\$ 778
\$ 73
\$ 12.548a
\$ -59x
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}