#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<meta name="twitter:title" content="[\w+\s?]+"\/>"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"<html lang="en">" & @CRLF & _
" <head>" & @CRLF & _
" <meta name="twitter:card" content="summary"/>" & @CRLF & _
" <meta name="twitter:title" content="My Favorite Girlfriend"/> ✅" & @CRLF & _
" <meta name="twitter:site" content="@Hulu"/>" & @CRLF & _
" <meta name="twitter:description" content="A chef's life gets complicated when he falls for a beautiful young woman who has multiple personalities."/>" & @CRLF & _
" <meta property="og:title" content="My Favorite Girlfriend"/> ✅" & @CRLF & _
" <meta property="og:site_name" content="Hulu"/>" & @CRLF & _
" <meta property="og:type" content="movie"/>" & @CRLF & _
" </head>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")