import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<meta name=\"twitter:title\" content=\"[\\w+\\s?]+\"\\/>";
final String string = "<!DOCTYPE html>\n"
+ "<html lang=\"en\">\n"
+ " <head>\n"
+ " <meta name=\"twitter:card\" content=\"summary\"/>\n"
+ " <meta name=\"twitter:title\" content=\"My Favorite Girlfriend\"/> ✅\n"
+ " <meta name=\"twitter:site\" content=\"@Hulu\"/>\n"
+ " <meta name=\"twitter:description\" content=\"A chef's life gets complicated when he falls for a beautiful young woman who has multiple personalities.\"/>\n"
+ " <meta property=\"og:title\" content=\"My Favorite Girlfriend\"/> ✅\n"
+ " <meta property=\"og:site_name\" content=\"Hulu\"/>\n"
+ " <meta property=\"og:type\" content=\"movie\"/>\n"
+ " </head>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}