# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<meta name=\"twitter:title\" content=\"[\w+\s?]+\"\/>"
test_str = ("<!DOCTYPE html>\n"
"<html lang=\"en\">\n"
" <head>\n"
" <meta name=\"twitter:card\" content=\"summary\"/>\n"
" <meta name=\"twitter:title\" content=\"My Favorite Girlfriend\"/> ✅\n"
" <meta name=\"twitter:site\" content=\"@Hulu\"/>\n"
" <meta name=\"twitter:description\" content=\"A chef's life gets complicated when he falls for a beautiful young woman who has multiple personalities.\"/>\n"
" <meta property=\"og:title\" content=\"My Favorite Girlfriend\"/> ✅\n"
" <meta property=\"og:site_name\" content=\"Hulu\"/>\n"
" <meta property=\"og:type\" content=\"movie\"/>\n"
" </head>\n"
"</html>")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.