use strict;
my $str = '<?xml version="1.0" encoding="windows-1251" ?><ELEM_LIST><ELEM PLAYER_NAME="Плеер" STATUS="playing"><START_TIME>15:49:41</START_TIME><BLK_TYPE>М</BLK_TYPE><TYPE>М</TYPE><NAME>Heathens</NAME><ARTIST>Twenty One Pilots</ARTIST><AUTHOR></AUTHOR><ALBUM></ALBUM><DBID></DBID><FILE_NAME>H:\\Radio\\Music\\Twenty One Pilots - Heathens.mp3</FILE_NAME><DURATION>00:03:10</DURATION></ELEM><ELEM PLAYER_NAME="Плеер" STATUS="preloaded"><START_TIME></START_TIME><BLK_TYPE>М</BLK_TYPE><TYPE>Д</TYPE><NAME>ID #5</NAME><ARTIST>Jingle</ARTIST><AUTHOR></AUTHOR><ALBUM></ALBUM><DBID></DBID><FILE_NAME>H:\\Radio\\Jingle\'s\\ID #5.mp3</FILE_NAME><DURATION>00:00:01</DURATION></ELEM></ELEM_LIST>';
my $regex = qr/<(?<root>[A-Z_]+)(?: .*?>|>).*?<\/\k<root>>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}