// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<(?<root>[A-Z_]+)(?: .*?>|>).*?<\/\k<root>>").unwrap();
let string = "<?xml version=\"1.0\" encoding=\"windows-1251\" ?><ELEM_LIST><ELEM PLAYER_NAME=\"Плеер\" STATUS=\"playing\"><START_TIME>15:49:41</START_TIME><BLK_TYPE>М</BLK_TYPE><TYPE>М</TYPE><NAME>Heathens</NAME><ARTIST>Twenty One Pilots</ARTIST><AUTHOR></AUTHOR><ALBUM></ALBUM><DBID></DBID><FILE_NAME>H:\\Radio\\Music\\Twenty One Pilots - Heathens.mp3</FILE_NAME><DURATION>00:03:10</DURATION></ELEM><ELEM PLAYER_NAME=\"Плеер\" STATUS=\"preloaded\"><START_TIME></START_TIME><BLK_TYPE>М</BLK_TYPE><TYPE>Д</TYPE><NAME>ID #5</NAME><ARTIST>Jingle</ARTIST><AUTHOR></AUTHOR><ALBUM></ALBUM><DBID></DBID><FILE_NAME>H:\\Radio\\Jingle's\\ID #5.mp3</FILE_NAME><DURATION>00:00:01</DURATION></ELEM></ELEM_LIST>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}