import Foundation
let pattern = #"<(?<root>[A-Z_]+)(?: .*?>|>).*?<\/\k<root>>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"<?xml version="1.0" encoding="windows-1251" ?><ELEM_LIST><ELEM PLAYER_NAME="Плеер" STATUS="playing"><START_TIME>15:49:41</START_TIME><BLK_TYPE>М</BLK_TYPE><TYPE>М</TYPE><NAME>Heathens</NAME><ARTIST>Twenty One Pilots</ARTIST><AUTHOR></AUTHOR><ALBUM></ALBUM><DBID></DBID><FILE_NAME>H:\Radio\Music\Twenty One Pilots - Heathens.mp3</FILE_NAME><DURATION>00:03:10</DURATION></ELEM><ELEM PLAYER_NAME="Плеер" STATUS="preloaded"><START_TIME></START_TIME><BLK_TYPE>М</BLK_TYPE><TYPE>Д</TYPE><NAME>ID #5</NAME><ARTIST>Jingle</ARTIST><AUTHOR></AUTHOR><ALBUM></ALBUM><DBID></DBID><FILE_NAME>H:\Radio\Jingle's\ID #5.mp3</FILE_NAME><DURATION>00:00:01</DURATION></ELEM></ELEM_LIST>"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)