# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<(?<root>[A-Z_]+)(?: .*?>|>).*?<\/\k<root>>"
test_str = "<?xml version=\"1.0\" encoding=\"windows-1251\" ?><ELEM_LIST><ELEM PLAYER_NAME=\"Плеер\" STATUS=\"playing\"><START_TIME>15:49:41</START_TIME><BLK_TYPE>М</BLK_TYPE><TYPE>М</TYPE><NAME>Heathens</NAME><ARTIST>Twenty One Pilots</ARTIST><AUTHOR></AUTHOR><ALBUM></ALBUM><DBID></DBID><FILE_NAME>H:\\Radio\\Music\\Twenty One Pilots - Heathens.mp3</FILE_NAME><DURATION>00:03:10</DURATION></ELEM><ELEM PLAYER_NAME=\"Плеер\" STATUS=\"preloaded\"><START_TIME></START_TIME><BLK_TYPE>М</BLK_TYPE><TYPE>Д</TYPE><NAME>ID #5</NAME><ARTIST>Jingle</ARTIST><AUTHOR></AUTHOR><ALBUM></ALBUM><DBID></DBID><FILE_NAME>H:\\Radio\\Jingle's\\ID #5.mp3</FILE_NAME><DURATION>00:00:01</DURATION></ELEM></ELEM_LIST>"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.