# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/,*(\s*\b(?:cat|dog|animals|adam))\b/,\1/gm;t' <<< "I have a lot of animals, cat and a dog
I have a lot of animals cat and a dogy
I have a lot of animals, cat and a dogy"