import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",*(\\s*\\b(?:cat|dog|animals|adam))\\b";
final String string = "I have a lot of animals, cat and a dog\n\n"
+ "I have a lot of animals cat and a dogy\n"
+ "I have a lot of animals, cat and a dogy";
final String subst = ",\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}