const regex = new RegExp(',*(\\s*\\b(?:cat|dog|animals|adam))\\b', 'gm')
const str = `I have a lot of animals, cat and a dog
I have a lot of animals cat and a dogy
I have a lot of animals, cat and a dogy`;
const subst = `,\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);