package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m),*(\s*\b(?:cat|dog|animals|adam))\b`)
var str = `I have a lot of animals, cat and a dog
I have a lot of animals cat and a dogy
I have a lot of animals, cat and a dogy`
var substitution = ",\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}