#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b([8-9]|[1][0-6]):[0-5][0-9](\s)?(?i)\b"
Local $sString = "" & @CRLF & _
"February 13, 2022 0:22:41" & @CRLF & _
"February 13, 2022 7:59:41" & @CRLF & _
"February 13, 2022 8:22:41" & @CRLF & _
"February 13, 2022 9:22:41" & @CRLF & _
"February 13, 2022 10:22:41" & @CRLF & _
"February 13, 2022 11:59:59" & @CRLF & _
"February 13, 2022 12:22:41" & @CRLF & _
"February 13, 2022 13:22:41" & @CRLF & _
"February 13, 2022 14:22:41" & @CRLF & _
"February 13, 2022 15:22:41" & @CRLF & _
"February 13, 2022 16:59:41" & @CRLF & _
"February 13, 2022 17:22:41" & @CRLF & _
"February 13, 2022 18:22:41" & @CRLF & _
"February 13, 2022 19:22:41" & @CRLF & _
"February 13, 2022 20:22:41" & @CRLF & _
"February 13, 2022 21:22:41" & @CRLF & _
"February 13, 2022 22:22:41" & @CRLF & _
"February 13, 2022 23:22:41"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")