# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b([8-9]|[1][0-6]):[0-5][0-9](\s)?(?i)\b"
test_str = ("\n"
"February 13, 2022 0:22:41\n"
"February 13, 2022 7:59:41\n"
"February 13, 2022 8:22:41\n"
"February 13, 2022 9:22:41\n"
"February 13, 2022 10:22:41\n"
"February 13, 2022 11:59:59\n"
"February 13, 2022 12:22:41\n"
"February 13, 2022 13:22:41\n"
"February 13, 2022 14:22:41\n"
"February 13, 2022 15:22:41\n"
"February 13, 2022 16:59:41\n"
"February 13, 2022 17:22:41\n"
"February 13, 2022 18:22:41\n"
"February 13, 2022 19:22:41\n"
"February 13, 2022 20:22:41\n"
"February 13, 2022 21:22:41\n"
"February 13, 2022 22:22:41\n"
"February 13, 2022 23:22:41")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.