re = /\b([8-9]|[1][0-6]):[0-5][0-9](\s)?(?i)\b/m
str = '
February 13, 2022 0:22:41
February 13, 2022 7:59:41
February 13, 2022 8:22:41
February 13, 2022 9:22:41
February 13, 2022 10:22:41
February 13, 2022 11:59:59
February 13, 2022 12:22:41
February 13, 2022 13:22:41
February 13, 2022 14:22:41
February 13, 2022 15:22:41
February 13, 2022 16:59:41
February 13, 2022 17:22:41
February 13, 2022 18:22:41
February 13, 2022 19:22:41
February 13, 2022 20:22:41
February 13, 2022 21:22:41
February 13, 2022 22:22:41
February 13, 2022 23:22:41'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end