const regex = new RegExp('\\b([8-9]|[1][0-6]):[0-5][0-9](\\s)?(?i)\\b', 'gm')
const str = `
February 13, 2022 0:22:41
February 13, 2022 7:59:41
February 13, 2022 8:22:41
February 13, 2022 9:22:41
February 13, 2022 10:22:41
February 13, 2022 11:59:59
February 13, 2022 12:22:41
February 13, 2022 13:22:41
February 13, 2022 14:22:41
February 13, 2022 15:22:41
February 13, 2022 16:59:41
February 13, 2022 17:22:41
February 13, 2022 18:22:41
February 13, 2022 19:22:41
February 13, 2022 20:22:41
February 13, 2022 21:22:41
February 13, 2022 22:22:41
February 13, 2022 23:22:41`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}