$re = '/(^|[^0-9])(\(?0?[0-9]{2}\)?)?9 ?[0-9]{4} ?[0-9]{4}([^0-9]|$)/m';
$str = 'telefone (11) 9 9123 4567
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);