re = /(^|[^0-9])(\(?0?[0-9]{2}\)?)?9 ?[0-9]{4} ?[0-9]{4}([^0-9]|$)/m
str = 'telefone (11) 9 9123 4567
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end