// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^|[^0-9])(\(?0?[0-9]{2}\)?)?9 ?[0-9]{4} ?[0-9]{4}([^0-9]|$)").unwrap();
let string = "telefone (11) 9 9123 4567
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}