# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:#|\/\/)_+NOT_FOR_CUSTOMER_BEGIN_+(?:\n.*)*?\n(?:#|\/\/)_+NOT_FOR_CUSTOMER_END_+\n*//gm;t' <<< "i want this
#____NOT_FOR_CUSTOMER_BEGIN________
not this
nor this
#________NOT_FOR_CUSTOMER_END____
and this
//____NOT_FOR_CUSTOMER_BEGIN__
not this again
nor this again
//__________NOT_FOR_CUSTOMER_END____
and this again"