re = /^(?:#|\/\/)_+NOT_FOR_CUSTOMER_BEGIN_+(?:\n.*)*?\n(?:#|\/\/)_+NOT_FOR_CUSTOMER_END_+\n*/m
str = 'i want this
#____NOT_FOR_CUSTOMER_BEGIN________
not this
nor this
#________NOT_FOR_CUSTOMER_END____
and this
//____NOT_FOR_CUSTOMER_BEGIN__
not this again
nor this again
//__________NOT_FOR_CUSTOMER_END____
and this again'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result