import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:#|//)_+NOT_FOR_CUSTOMER_BEGIN_+(?:\\n.*)*?\\n(?:#|//)_+NOT_FOR_CUSTOMER_END_+\\n*";
final String string = "i want this\n"
+ "#____NOT_FOR_CUSTOMER_BEGIN________\n"
+ "not this\n"
+ "nor this\n"
+ "#________NOT_FOR_CUSTOMER_END____\n"
+ "and this\n"
+ "//____NOT_FOR_CUSTOMER_BEGIN__\n"
+ "not this again\n"
+ "nor this again\n"
+ "//__________NOT_FOR_CUSTOMER_END____\n"
+ "and this again";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}