const regex = new RegExp('^(?:#|//)_+NOT_FOR_CUSTOMER_BEGIN_+(?:\\n.*)*?\\n(?:#|//)_+NOT_FOR_CUSTOMER_END_+\\n*', 'gm')
const str = `i want this
#____NOT_FOR_CUSTOMER_BEGIN________
not this
nor this
#________NOT_FOR_CUSTOMER_END____
and this
//____NOT_FOR_CUSTOMER_BEGIN__
not this again
nor this again
//__________NOT_FOR_CUSTOMER_END____
and this again`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);