package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m) ?\n ?`)
var str = `1
2
3
4
`
var substitution = "\n "
fmt.Println(re.ReplaceAllString(str, substitution))
}