// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m) ?\n ?").unwrap();
let string = "1
2
3
4
";
let substitution = "\\n ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}