use strict;
my $str = '1
2
3
4
';
my $regex = qr/ ?\n ?/mp;
my $subst = '\\n ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";