import Foundation
let pattern = #" ?\n ?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1
2
3
4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)