#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<Item TimeStamp="(?<timestamp>\d*:\d*:\d*.\d*)"[[:blank:]]Duration="(?<duration>\d*:\d*:\d*.\d*)"[[:blank:]]Line="(?<scriptline>\d*)"[[:blank:]]File="(?<scriptfilename>.*)"[[:blank:]]Command="(?<command_name>\w*)"[[:blank:]]Type="(?<severity>\w*)">(?<message>[\D]*)\t(?<time>\d*.\d*)<\/Item>"
Local $sString = "<Item TimeStamp="00:33:12.88" Duration="00:00:00.00" Line="87" File="all_test_v2.tws" Command="print" Type="Info">Loading Result screen time is: -1</Item>" & @CRLF & _
"" & @CRLF & _
"<Item TimeStamp="00:32:32.10" Duration="00:00:00.00" Line="40" File="all_test_v2.tws" Command="print" Type="Info">Loading Search screen time 0.8045754</Item>" & @CRLF & _
"" & @CRLF & _
"<Item TimeStamp="00:32:31.16" Duration="00:00:00.00" Line="28" File="all_test_v2.tws" Command="print" Type="Info">Loading Splash screen time is: 4.3964327</Item>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")