// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<Item TimeStamp="(?<timestamp>\d*:\d*:\d*.\d*)"[[:blank:]]Duration="(?<duration>\d*:\d*:\d*.\d*)"[[:blank:]]Line="(?<scriptline>\d*)"[[:blank:]]File="(?<scriptfilename>.*)"[[:blank:]]Command="(?<command_name>\w*)"[[:blank:]]Type="(?<severity>\w*)">(?<message>[\D]*)\t(?<time>\d*.\d*)<\/Item>"#).unwrap();
let string = "<Item TimeStamp=\"00:33:12.88\" Duration=\"00:00:00.00\" Line=\"87\" File=\"all_test_v2.tws\" Command=\"print\" Type=\"Info\">Loading Result screen time is: -1</Item>
<Item TimeStamp=\"00:32:32.10\" Duration=\"00:00:00.00\" Line=\"40\" File=\"all_test_v2.tws\" Command=\"print\" Type=\"Info\">Loading Search screen time 0.8045754</Item>
<Item TimeStamp=\"00:32:31.16\" Duration=\"00:00:00.00\" Line=\"28\" File=\"all_test_v2.tws\" Command=\"print\" Type=\"Info\">Loading Splash screen time is: 4.3964327</Item>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}