using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<Item TimeStamp=""(?<timestamp>\d*:\d*:\d*.\d*)""[[:blank:]]Duration=""(?<duration>\d*:\d*:\d*.\d*)""[[:blank:]]Line=""(?<scriptline>\d*)""[[:blank:]]File=""(?<scriptfilename>.*)""[[:blank:]]Command=""(?<command_name>\w*)""[[:blank:]]Type=""(?<severity>\w*)"">(?<message>[\D]*)\t(?<time>\d*.\d*)<\/Item>";
string input = @"<Item TimeStamp=""00:33:12.88"" Duration=""00:00:00.00"" Line=""87"" File=""all_test_v2.tws"" Command=""print"" Type=""Info"">Loading Result screen time is: -1</Item>
<Item TimeStamp=""00:32:32.10"" Duration=""00:00:00.00"" Line=""40"" File=""all_test_v2.tws"" Command=""print"" Type=""Info"">Loading Search screen time 0.8045754</Item>
<Item TimeStamp=""00:32:31.16"" Duration=""00:00:00.00"" Line=""28"" File=""all_test_v2.tws"" Command=""print"" Type=""Info"">Loading Splash screen time is: 4.3964327</Item>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}