import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*(?=[a-z]{3})[abc]{0,2}[d-z])[a-zA-Z]+$";
final String string = "abc\n"
+ "abcbcbcb\n"
+ "aaaaaaaa\n"
+ "AabcbaDEF\n"
+ "ABCDEFG\n"
+ "abcDEfgH\n"
+ "AbcDefG\n\n"
+ "abcd\n"
+ "AbcdE\n"
+ "AabcbcdefgK";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}