import re
regex = re.compile(r"^(?!.*(?=[a-z]{3})[abc]{0,2}[d-z])[a-zA-Z]+$", flags=re.MULTILINE)
test_str = ("abc\n"
"abcbcbcb\n"
"aaaaaaaa\n"
"AabcbaDEF\n"
"ABCDEFG\n"
"abcDEfgH\n"
"AbcDefG\n\n"
"abcd\n"
"AbcdE\n"
"AabcbcdefgK")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")