using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z\.\*+!\-_?$%&=<>][a-zA-Z0-9\.\*+!\-_?$%&=<>]+\/[a-zA-Z\.\*+!\-_?$%&=<>][a-zA-Z0-9\.\*+!\-_?$%&=<>]+)|([a-zA-Z\.\*+!\-_?$%&=<>][a-zA-Z0-9\.\*+!\-_?$%&=<>]+\/[a-zA-Z\.\*+!\-_?$%&=<>\/])|([a-zA-Z\.\*+!\-_?$%&=<>]\/[a-zA-Z\.\*+!\-_?$%&=<>][a-zA-Z0-9\.\*+!\-_?$%&=<>]+)|([a-zA-Z\.\*+!\-_?$%&=<>]\/[a-zA-Z\.\*+!\-_?$%&=<>\/])|([a-zA-Z\.\*+!\-_?$%&=<>][a-zA-Z0-9\.\*+!\-_?$%&=<>]+)|([a-zA-Z\.\*+!\-_?$%&=<>\/])";
string input = @"+ /
foo bar2
js/foo
atom?
user/atom?
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}