$re = '/([a-zA-Z\.\*+!\-_?$%&=<>][a-zA-Z0-9\.\*+!\-_?$%&=<>]+\/[a-zA-Z\.\*+!\-_?$%&=<>][a-zA-Z0-9\.\*+!\-_?$%&=<>]+)|([a-zA-Z\.\*+!\-_?$%&=<>][a-zA-Z0-9\.\*+!\-_?$%&=<>]+\/[a-zA-Z\.\*+!\-_?$%&=<>\/])|([a-zA-Z\.\*+!\-_?$%&=<>]\/[a-zA-Z\.\*+!\-_?$%&=<>][a-zA-Z0-9\.\*+!\-_?$%&=<>]+)|([a-zA-Z\.\*+!\-_?$%&=<>]\/[a-zA-Z\.\*+!\-_?$%&=<>\/])|([a-zA-Z\.\*+!\-_?$%&=<>][a-zA-Z0-9\.\*+!\-_?$%&=<>]+)|([a-zA-Z\.\*+!\-_?$%&=<>\/])/';
$str = '+ /
foo bar2
js/foo
atom?
user/atom?
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);