re = /([a-zA-Z\.\*+!\-_?$%&=<>][a-zA-Z0-9\.\*+!\-_?$%&=<>]+\/[a-zA-Z\.\*+!\-_?$%&=<>][a-zA-Z0-9\.\*+!\-_?$%&=<>]+)|([a-zA-Z\.\*+!\-_?$%&=<>][a-zA-Z0-9\.\*+!\-_?$%&=<>]+\/[a-zA-Z\.\*+!\-_?$%&=<>\/])|([a-zA-Z\.\*+!\-_?$%&=<>]\/[a-zA-Z\.\*+!\-_?$%&=<>][a-zA-Z0-9\.\*+!\-_?$%&=<>]+)|([a-zA-Z\.\*+!\-_?$%&=<>]\/[a-zA-Z\.\*+!\-_?$%&=<>\/])|([a-zA-Z\.\*+!\-_?$%&=<>][a-zA-Z0-9\.\*+!\-_?$%&=<>]+)|([a-zA-Z\.\*+!\-_?$%&=<>\/])/
str = '+ /
foo bar2
js/foo
atom?
user/atom?
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end