import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z\\.\\*+!\\-_?$%&=<>][a-zA-Z0-9\\.\\*+!\\-_?$%&=<>]+\\/[a-zA-Z\\.\\*+!\\-_?$%&=<>][a-zA-Z0-9\\.\\*+!\\-_?$%&=<>]+)|([a-zA-Z\\.\\*+!\\-_?$%&=<>][a-zA-Z0-9\\.\\*+!\\-_?$%&=<>]+\\/[a-zA-Z\\.\\*+!\\-_?$%&=<>\\/])|([a-zA-Z\\.\\*+!\\-_?$%&=<>]\\/[a-zA-Z\\.\\*+!\\-_?$%&=<>][a-zA-Z0-9\\.\\*+!\\-_?$%&=<>]+)|([a-zA-Z\\.\\*+!\\-_?$%&=<>]\\/[a-zA-Z\\.\\*+!\\-_?$%&=<>\\/])|([a-zA-Z\\.\\*+!\\-_?$%&=<>][a-zA-Z0-9\\.\\*+!\\-_?$%&=<>]+)|([a-zA-Z\\.\\*+!\\-_?$%&=<>\\/])";
final String string = "+ /\n"
+ "foo bar2\n"
+ "js/foo\n"
+ "atom?\n"
+ "user/atom?\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}