# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\B\p{Lu}/ \0/g;t' <<< "HelloEveryOne, СаломБаХама, Ҳама дарПеши ҷаҳонЯк мебошадАммо."