package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\B\p{Lu}`)
var str = `HelloEveryOne, СаломБаХама, Ҳама дарПеши ҷаҳонЯк мебошадАммо.`
var substitution = " \0"
fmt.Println(re.ReplaceAllString(str, substitution))
}