$re = '/\B\p{Lu}/';
$str = 'HelloEveryOne, СаломБаХама, Ҳама дарПеши ҷаҳонЯк мебошадАммо.';
$subst = " \0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;