re = /\B\p{Lu}/
str = 'HelloEveryOne, СаломБаХама, Ҳама дарПеши ҷаҳонЯк мебошадАммо.'
subst = ' \\0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result