#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?=(?:[a-z0-9]*[a-z]))(?=(?:[a-z0-9]*[0-9]){3})[a-z0-9]{10,}$"
Local $sString = "X6JV2YUW8T" & @CRLF & _
"JN1H86LEKA" & @CRLF & _
"111JEJE134" & @CRLF & _
"A111111111" & @CRLF & _
"ABCDEFGHIJ" & @CRLF & _
"0123456789" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"X6JV2YUW8T => True" & @CRLF & _
"JN1H86LEKA => True" & @CRLF & _
"111JEJE134 => True" & @CRLF & _
"A111111111 => True" & @CRLF & _
"ABCDEFGHIJ => False" & @CRLF & _
"0123456789 => False"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")