use strict;
my $str = 'X6JV2YUW8T
JN1H86LEKA
111JEJE134
A111111111
ABCDEFGHIJ
0123456789
X6JV2YUW8T => True
JN1H86LEKA => True
111JEJE134 => True
A111111111 => True
ABCDEFGHIJ => False
0123456789 => False';
my $regex = qr/^(?=(?:[a-z0-9]*[a-z]))(?=(?:[a-z0-9]*[0-9]){3})[a-z0-9]{10,}$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}